解决Deprecated: mysql_connect(): The mysql extension

<p>php 5个版本,5.2、5.3、5.4、5.5,怕跟不上时代,新的服务器直接上5.5,但是程序出现如下错误:Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in,看意思就很明了,说mysql_connect这个模块将在未来弃用,请你使用mysqli或者PDO来替代。</p><p>解决方法1:</p><p>禁止php报错</p><p>display_errors = On</p><p>改为</p><p>display_errors = Off</p><p>鉴于这个服务器都是给用户用的,有时候他们需要报错(…都是给朋友用的,^_^),不能这做,让他们改程序吧,看方案2.</p><p>解决方法2:</p><p>常用的php语法连接mysql如下</p><pre class="brush:php;toolbar:false">&lt;?php $link=mysql_connect(&#39;localhost&#39;,&#39;user&#39;,&#39;password&#39;); mysql_select_db(&#39;dbname&#39;,$link); 改成mysqi &lt;?php $link=mysqli_connect(&#39;localhost&#39;,&#39;user&#39;,&#39;password&#39;,&#39;dbname&#39;); 常用mysql建表SQL如下</pre><pre class="brush:php;toolbar:false">&lt;?php //老的 mysql_query(&#39;CREATETEMPORARYTABLE`table`&#39;,$link); //新的 mysqli_query($link,&#39;CREATETEMPORARYTABLE`table`&#39;);</pre><p>解决方法三:</p><p>在php程序代码里面设置报警级别</p><pre class="brush:php;toolbar:false">&lt;?php error_reporting(E_ALL^E_DEPRECATED);</pre><p>Deprecated的问题就这样解决掉了,不过还是建议大家尽快取消mysql的用户,全部都走向mysqli或者mysqlnd等等。mysql确实是太不安全而且太老旧了。</p>
RangeTime:0.009274s
RangeMem:205.34 KB
返回顶部 留言