Error: mysql-devel conflicts with MySQL-devel-comm

<p>CentOS 5.5 系统安装使用 yum 安装 mysql 报如下错误:</p><p>[root@dc/etc/yum.repos.d]# yum install -y mysql*</p><p>Loaded plugins: fastestmirror</p><p>Loading mirror speeds from cached hostfile</p><p>* base: mirrors.btte.net</p><p>* extras: mirrors.btte.net</p><p>* updates: mirrors.btte.net</p><p>Setting up Install Process</p><p>Resolving Dependencies</p><p>--&gt; Running transaction check</p><p>---&gt; Package mysql.i386 0:5.0.95-1.el5_7.1 set to be updated</p><p>---&gt; Package mysql.x86_64 0:5.0.95-1.el5_7.1 set to be updated</p><p>---&gt; Package mysql-bench.x86_64 0:5.0.95-1.el5_7.1 set to be updated</p><p>---&gt; Package mysql-connector-odbc.x86_64 0:3.51.26r1127-2.el5 set to be updated</p><p>--&gt; Processing Dependency: libodbcinst.so.1()(64bit) for package: mysql-connector-odbc</p><p>---&gt; Package mysql-connector-odbc64.x86_64 0:5.1.8-1.el5 set to be updated</p><p>--&gt; Processing Dependency: libodbcinst.so.2()(64bit) for package: mysql-connector-odbc64</p><p>---&gt; Package mysql-devel.i386 0:5.0.95-1.el5_7.1 set to be updated</p><p>---&gt; Package mysql-devel.x86_64 0:5.0.95-1.el5_7.1 set to be updated</p><p>---&gt; Package mysql-server.x86_64 0:5.0.95-1.el5_7.1 set to be updated</p><p>--&gt; Processing Dependency: perl-DBD-MySQL for package: mysql-server</p><p>---&gt; Package mysql-test.x86_64 0:5.0.95-1.el5_7.1 set to be updated</p><p>--&gt; Running transaction check</p><p>---&gt; Package perl-DBD-MySQL.x86_64 0:3.0007-2.el5 set to be updated</p><p>---&gt; Package unixODBC-libs.x86_64 0:2.2.11-10.el5 set to be updated</p><p>---&gt; Package unixODBC64-libs.x86_64 0:2.2.14-3.el5 set to be updated</p><p>--&gt; Processing Conflict: mysql-devel conflicts MySQL-devel</p><p>--&gt; Processing Conflict: mysql-devel conflicts MySQL-devel</p><p>--&gt; Finished Dependency Resolution</p><p>mysql-devel-5.0.95-1.el5_7.1.i386 from updates has depsolving problems</p><p> --&gt; mysql-devel conflicts with MySQL-devel-community</p><p>mysql-devel-5.0.95-1.el5_7.1.x86_64 from updates has depsolving problems</p><p> --&gt; mysql-devel conflicts with MySQL-devel-community</p><p>Error: mysql-devel conflicts with MySQL-devel-community</p><p>You could try using --skip-broken to work around the problem</p><p>You could try running: package-cleanup --problems</p><p> package-cleanup --dupes</p><p> rpm -Va --nofiles --nodigest</p><p>The program package-cleanup is found in the yum-utils package</p><p></p><p>解决方法:</p><p>[root@dc/etc/yum.repos.d]# rpm -qa|grep -i mysql</p><p>MySQL-devel-community-5.1.58-1.rhel4</p><p>[root@dc/etc/yum.repos.d]# rpm -e MySQL-devel-community</p>
RangeTime:0.006848s
RangeMem:206.61 KB
返回顶部 留言